Walther Forums banner

1 - 7 of 7 Posts

·
Registered
Joined
·
55 Posts
Discussion Starter #1
my german p99 in .40 has black mag followers and sometimes jams open after pressing slide release lever( first bullet holds open slide and does not chamber).  would the new blue follower mags fix this? if so, i need sw/walther contact info. thanx
 

·
Registered
Joined
·
821 Posts
I'm batting 0 for 2 tonight as far as helping people figure out their problem, but I do have a question for you...  Is your P99 a 40?

I could be wrong (and I'm being cautious here) but I believe the blue colored followers are for the 40 P99, and deal directly with the problem of premature slide lockback.  So if you have a 9mm, then that probably isn't the cause of your problem.

Lemme know, and have a good night!

-stunks
 

·
Registered
Joined
·
55 Posts
Discussion Starter #3
[b said:
Quote[/b] (stunksinatl @ July 11 2004,12:22)]I'm batting 0 for 2 tonight as far as helping people figure out their problem, but I do have a question for you...  Is your P99 a 40?

I could be wrong (and I'm being cautious here) but I believe the blue colored followers are for the 40 P99, and deal directly with the problem of premature slide lockback.  So if you have a 9mm, then that probably isn't the cause of your problem.

Lemme know, and have a good night!

-stunks
yes .40 cal
 

·
Registered
Joined
·
1 Posts
Alex,

Had the same problem with my German P99, 40.  I had to replace the factory orange follower magazines with the updated blue follower magazines. This corrected the problem.

Hope this helps.

JB
 

·
Registered
Joined
·
55 Posts
Discussion Starter #7
[b said:
Quote[/b] (alex @ July 23 2004,1:02)]thank you stunks and vanderbilt
i mailed in only one of my black follower mags to see the quality they send back. if good i'll send in the other one later
 
1 - 7 of 7 Posts
Top