Walther Forums banner

1 - 10 of 10 Posts

·
Registered
Joined
·
17 Posts
Discussion Starter · #1 ·
I have a Q5 Match that I have added a Vortex Venom to. Mounted up just fine with one of the plates included with the gun. The problem is that the point of impact is 1-2" low at 10 yards. I've cranked the Venom's vertical adjustment as far as it goes, but it still shoots low.

Since this will be for Carry Optics use in competition, this POA/POI discrepancy won't work.

Has anyone else had this issue?
 

·
Registered
Joined
·
30 Posts
I have the Q4 Tac and had to crank and crank on the venom adjustment to get the POI up high enough but was finally able to get it dead on. I agree with check the plate and contact Vortex.
 

·
Registered
Joined
·
46 Posts
Unless there is an obvious issue with the way its mounted, which seems hard to believe, its either 1) flinch, 2) defective optic, or 3) user error on adjustments.

Does the optic still adjust through it’s adjustment range, or is it locked into place now?
 

·
Registered
Joined
·
17 Posts
Discussion Starter · #6 ·
Unless there is an obvious issue with the way its mounted, which seems hard to believe, its either 1) flinch, 2) defective optic, or 3) user error on adjustments.

Does the optic still adjust through it’s adjustment range, or is it locked into place now?
Not sure which plate I used, but it was the only one that fit the Venom.

I would like to say that I have my flinch under control (most of the time). I'm confidant that isn't the case here.

Not sure about defective optic.

I checked the optic's instructions to make sure that I wasn't going full retard. Confidant that I'm making adjustments correctly. The issue is the vertical adjustment has been cranked so high that I'm not feeling resistnace on the dial...a LOT of resistance. Enough that makes me think something is going to break if I try to keep going (or I strip the adjustment "screw").

Some pics of the gun.





 

·
Registered
Joined
·
21 Posts
Not sure if it worked out for you Gryff. Just put a venom on a Q4 today and checked it at home. I noticed the dot sits very high with my normal grip, and when I tried to bring the "group" up, it looked the dot was not moving at all with nearly 2 full turns.

Max elevation adjustment is 130 moa and that's a little over 4 full turns. Shouldn't force it when you feel resistance.

What I did was to turn it ("group") all the way down, then nearly all the way up again. Then I noticed the dot is showing a more reasonable POA. There maybe some contact issues with the adjustment dial.
 

·
Registered
Joined
·
247 Posts
I put a Viper on my SF but the Viper has lock adjustment screws that need to be loosened before adjusting. I don't "think" the Venom has those. Anyway no issues adjusting it.
 

·
Registered
Joined
·
17 Posts
Discussion Starter · #10 ·
An email into Vortex customer service got back the recommendation of this:

https://www.amazon.com/gp/product/B00L5RS2FM

Ironically, I put it on backwards initially (didn't realize it was slanted) and gun shot even lower. WTF?!

Then realized that I was a retard and reversed the shim. Now was impacting super high, but there was plenty of adjustment room in the sight to bring it back down to a perfect POA/POI.

Happy camper!

You can see the shim in place under the sight here.



This was the trio that made the trip to the range with me that day.

 
1 - 10 of 10 Posts
Top