Walther Forums banner

1 - 5 of 5 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
After running like a machine for thousands of rounds this Q5 SF has been giving me fits at the matches. Failure to go into battery, failure to extract & eject and now the slide won't lock back after the last round. I've pretty much fixed the failure to go into battery with changing OAL on the ammo and projectile shape. But after replacing the extractor and spring and trying 2 new mags, it went to crap on stage 4 today. It doesn't matter what ammo it runs or if I change out the Springco 14lbs recoil spring assembly for the stock one. New mags, old mags, every 2-3 mags full if fails to slide lock when empty. I almost threw it over the berm like a golfer with a crap putter today. I'm out of options and need some help.
 

·
Registered
Joined
·
34 Posts
Could be you have some gunk around the slide release lever preventing it from fully moving up or your something between the lever and the notch in the slide.


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
4 Posts
Discussion Starter #3
I believe I have found the problem. When I took the grip off it was missing 2 of the plastic magazine guides on the right side of the frame. There are two on each side of the frame held in by the grip and evidently the last time I had the grip off they fell out. With the ones missing on the right the mag has all sorts of side to side play causing a pile of problems. I ordered two more from carlwalther.com and this should take care of it. I hope!
 

·
Registered
Joined
·
245 Posts
Yep. When I changed the Wifes OEM grip to the LOK THin yesterday the R. side plastic spacers promptly fell out. BTW. Both our 5 and 4 SF's feed my 1.148 147gr. DG flatpoints perfectly.
 
1 - 5 of 5 Posts
Top