Walther Forums banner
1 - 9 of 9 Posts

·
Registered
Joined
·
84 Posts
Discussion Starter · #1 ·
Have a Sig P320 with a Romeo 1 red dot. Not crazy about the pistol but love the Romeo 1. It has many features the others don't have such as adjustable brightness, Motion Activated Control and a top load battery. Cost is above that of the Viper/Venom but much less than a Trijicon.
Am planning on getting a Q5 Match and would like to mount a Romeo 1 on it. Am told the plates supplied by Walther with the Q5 are only for Trijicon, Leupold and Docter red dots.
Would anyone know if one of these plates could be adapted to mount a Romeo 1? Perhaps someone might know a vendor who could make one of these plates work with a Romeo 1.
I checked with Sig and the plates they can supply with their red dot are for other brands but not Walther.
Any help much appreciated!
 

·
Registered
Joined
·
5 Posts
Have a Sig P320 with a Romeo 1 red dot. Not crazy about the pistol but love the Romeo 1. It has many features the others don't have such as adjustable brightness, Motion Activated Control and a top load battery. Cost is above that of the Viper/Venom but much less than a Trijicon.
Am planning on getting a Q5 Match and would like to mount a Romeo 1 on it. Am told the plates supplied by Walther with the Q5 are only for Trijicon, Leupold and Docter red dots.
Would anyone know if one of these plates could be adapted to mount a Romeo 1? Perhaps someone might know a vendor who could make one of these plates work with a Romeo 1.
I checked with Sig and the plates they can supply with their red dot are for other brands but not Walther.
Any help much appreciated!
Did you find a plate that works with your Romeo 1? I am in the same boat here. Don't want to buy a different dot..
 

·
Registered
Joined
·
269 Posts
I bought a RTS2 mount for my FTP Alpha 3. I'm not 100% positive, but I think Sig changed the mount pattern between the Romeo 1 and the Max and 360 which I think are the models that take the RTS2 mount.
 

·
Registered
Joined
·
4 Posts
RTS2 mount will not work. Screws that come with the mount are too large for the Romeo1 that I have. Also the holes do not line up exactly (very close, but not exact). It may be because my Romeo 1 is about 2 years old, which may have been before they changed the pattern.
 
1 - 9 of 9 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top