Walther Forums banner

1 - 4 of 4 Posts

·
Registered
Joined
·
354 Posts
Discussion Starter #1
Please note I have put thousands apon thousands of rounds through this gun, and treated it pretty rough. The gun still fires but 1 out of 80 rounds jams.

So I was at the range shooting the firearm that has never jammed in its life, when.... it jammed. My P99 the one I trust my life happiness, and pleasure to failed. Well I kept shooting trying to figure out if I hadnt cleaned it, the extractor was messed up etc.

The issue - the shell would still stayin the barrel, obviously a extractor issue.

Day 2 - Cleaned happy and I assumed back to flawless. I shoot and all of a sudden it jams again. My buddy pulls out his HK and slowly lets his slide go forward as we watch the round slide behind the extractor. I check mind everything looks as if its functioning properly. Then I notice I HAVE NO EJECTOR ROD STICKING FORWARD.

The walther kept shooting without a ejector.


Anyone know where to get replacement parts for cheap?
 

·
Registered
Joined
·
1,201 Posts
You have no ejector rod???!!!! Holy cow. Did it break? I'd like to see a picture if you can.

I'd call S&W and get a replacement. I can't look at mine right now, but I doubt it would be that hard to replace that.
 

·
Registered
Joined
·
53 Posts
hope the SW warranty service will take care of it for you. were you using steel case rounds like Wolf? they're harder on the ejector and extractor.
 

·
Registered
Joined
·
55 Posts
shit.....sorry to hear this.  i looked at the manual and my pistol and it looks like the ejector is embedded in a little plastic triangular shaped  'box' that is pinned in the frame with a roll pin.  the box contains other parts but is not complicated.  i would call walther usa first to get info on how to procede
 
1 - 4 of 4 Posts
Top