Walther Forums banner

1 - 9 of 9 Posts

·
Registered
Joined
·
18 Posts
Discussion Starter #1
I put another 350 rounds through my P99 .40 on Sunday morning. No problems at all still. The P99 fired with no problems at all. What a great gun.

I got my Mepro Nite Sites put on today with help from Dr. Lunde. I'm excited to get out and try them.

-- Sweaty
 

·
Registered
Joined
·
18 Posts
Discussion Starter #3
Ken,

Thanks again for the help. I can't wait to see those things in the dark.

As for lunch. There'll be other times. As it is we got hosed, the cafeteria closed at 1:30 and we got there at exactly that time. Oh well, next time.

Scott
 

·
Registered
Joined
·
127 Posts
Now you guys have went and done it. I'm off tomorrow and have the urge to go shoot mine. I guess I'll have to stop at Wally world on the way home for some 100rd packs.

It's a tough job, but somebody's gotta do it
 

·
Registered
Joined
·
1,283 Posts
Okay, took my P99 .40 for it's first spin today. While I was wildly impressed with it's accuracy - easily comparable to my 9's, I did suffer the dreaded "slide locked back with rounds still in the magazine" failure about 4 times out of about 60 rounds.

So what do I look for, or ask Walther to do about it? Is it the magazines (all have the orange followers)? Is it the slide stop spring?

Or just normal break-in?

Advice please?

Never have my 9's done that.

James
 

·
Registered
Joined
·
112 Posts
It is the mags! Send them back to Smith and Walther and they will send you new ones. You need the ones with the blue follower. It is totally redesigned so the bullets coming up dont touch the slide stop lever.
 
1 - 9 of 9 Posts
Top