Walther Forums banner

1 - 5 of 5 Posts

·
Registered
Joined
·
39 Posts
Discussion Starter #1
I have a P99 in 9. It has functioned flawlessly with several brands of ball ammo at the range. When carried, I use Speer Gold Dot JHP. The other day I put a fresh mag in with the Speer and it had problems stripping off or chambering the rounds. I tried this several times. The slide would not return completely to battery without a manual assist. Any ideas? Do I need to polish the feedramp?
 

·
Registered
Joined
·
411 Posts
Are you pulling the slide all the way back and releasing it or are you easing it down?
You need to pull and release. Do not ride the slide closed with your hand, and don't bother with the slide stop lever.
Don't polish the feedramp, owning a Dremel does not make you a gunsmith.
I'll bet you it's human error rather than a weapon malfunction.
 

·
Registered
Joined
·
1,180 Posts
I'd suggest trying a different brand of hollowpoint. That way you can determine whether it's you or the round.

FWIW, my .40 feeds Fed. Hydra-Shoks without problems.

Good luck.
 

·
Registered
Joined
·
39 Posts
Discussion Starter #4
Definitely not riding the slide. I will try some different ammo, but ideally the pistol should feed most ammo.

I would not use a dremel to polish the slide. Too drastic.
 

·
Registered
Joined
·
539 Posts
Indeed, ideally the pistol should eat all ammo. I haven't heard of too many types that have given people trouble with the P99. Thanks for sharing. I just ordered a smorgasboard of different ammo types to see how picky mine is.
 
1 - 5 of 5 Posts
Top